Laravel 5.2 — Ошибка при установке laravel с использованием композитора с git bash

Вопрос:

Я новичок в laravel, и при установке laravel с использованием композитора я вижу ошибку. Я попытался найти решение, но ничего не нашел. Я также попробовал обновление композитора. Но при установке все еще стоит проблема, ниже приведена команда.

COMMAND:

composer create-project --prefer-dist laravel/laravel cms 5.2

ОШИБКА:

Неустранимая ошибка: require(): Требуется неудачное открытие: C:\xampp\htdocs\cms\bootstrap/../vendor/autoload.php ‘(include_path =’ C:\xampp\php\PEAR ‘) в C:\xampp\htdocs\cms\bootstrap\autoload.php в строке 17 PHP Предупреждение: require (C:\xampp\htdocs\cms\bootstrap/../vendor/autoload.php): не удалось открыть поток: нет такого файла или каталога в C:\xampp\htdocs\cms\bootstrap\autoload.php в строке 17 PHP Неустранимая ошибка: require(): Не удалось выполнить открытие: C:\xampp\htdocs\cms\bootstrap/../vendor/autoload.php ‘( include_path = ‘C:\xampp\php\PEAR’) в C:\xampp\htdocs\cms\bootstrap\autoload.php в строке 17 Скрипт php artisan с явным компилятором обрабатывает событие pre-update-cmd, возвращенное с кодом ошибки 255

Я попытался переустановить композитор, и проблема все же возникла. заранее спасибо

Лучший ответ:

Попробуй это:

composer create-project --prefer-dist laravel/laravel cms "5.2.*"

Примечание * Если у вас уже есть каталог cms, сначала удалите его, прежде чем запускать указанную выше команду.

Подробнее: https://laravel.com/docs/5.2/installation#installing-laravel

Ответ №1

Запуск composer dump-autoload позволит решить эту ошибку.

Оцените статью
TechArks.Ru
Добавить комментарий